Автор Тема: Ошибка после добавления новой роли в конфигурации (УТ) - Управление торговлей 8  (Прочитано 23837 раз)

0 Пользователей и 1 Гость просматривают эту тему.

iPRG Team

  • Administrator
  • Full Member
  • *****
  • Сообщений: 188
    • Просмотр профиля
Re: Добавила роль в Бухгалтерия предприятия (2.0.55.5)
« Ответ #10 : 10 Февраль 2014 Понедельник 12:21:23 »
У вас Ошибка в процедуре УстановитьЗначениеПоУмолчанию
Скорей всего у вашей новой роли нет доступа на запись для: РегистрыСведений.НастройкиПользователей

Наталья

  • Newbie
  • *
  • Сообщений: 1
    • Просмотр профиля
Добавила роль в Бухгалтерия предприятия (2.0.55.5) , в общем модуле УправлениеПользователями добавила запись, при входе пользователем выдает ошибку
{ОбщийМодуль.УправлениеПользователями.Модуль(135)}: Ошибка при вызове метода контекста (Записать)
   МенеджерЗаписи.Записать(Истина);
по причине:
Нарушение прав доступа!
Подскажите пожалуйста , что можно с этим сделать?
« Последнее редактирование: 31 Январь 2014 Пятница 04:05:14 от Наталья »

iPRG Team

  • Administrator
  • Full Member
  • *****
  • Сообщений: 188
    • Просмотр профиля
Добавление новой роли для ЗУП 8.2 отличается
« Ответ #8 : 08 Май 2013 Среда 15:56:19 »
Чтобы добавить новую роль в конфигурцию 1С 8.2 "Зарплата и управление персоналом":

Сначала добавляем саму роль в ветку: Общие-Роли
Далее в конфигураторе открываем "Общие модули" и там модуль "ПолныеПрава", ищем:
Функция ЕстьДоступныеПраваДляЗапускаКонфигурации() Экспорт
    //Было так
   //Возврат РольДоступна("ПолныеПрава")   ИЛИ РольДоступна("Пользователь");   
   //Добавляем например новую роль "ТолькоПросмотр"
   Возврат РольДоступна("ПолныеПрава")ИЛИ РольДоступна("Пользователь") ИЛИ РольДоступна("ТолькоПросмотр");   
КонецФункции

Luador

  • Newbie
  • *
  • Сообщений: 1
    • Просмотр профиля
Все верно...Для корректного добавления новой роли нужно УРЕЗАТЬ права у стандартной роли "Бухгалтер" до необходимых (например просмотр-чтение) и назначать ее ВСЕМ бухгалтерам. А для конкретного рабочего места, например "Кассир", создавать доп. роль "Кассир" с необходимыми правами на ввод, изменение и т.д. Именно так сделано в типовой бухгалтерии: есть роль "бухгалтер", а дополнительно есть роль "ПравоГлавногоБухгалтера". Т.е. для глав буха будут установлены 2 роли Бухгалтер и ПравоГлавногоБухгалтера.

iPRG Team

  • Administrator
  • Full Member
  • *****
  • Сообщений: 188
    • Просмотр профиля
Наверное 1С так и задумали, (это я про 1С бухгалтерия предприятия 8.1) сделали 2 стандартные роли ПолныеПрава и Бухгалтер, нужно обязательно выбрать одну из этих ролей, а уже те роли которые ты создаешь в ручную, будут прибавляться к этим стандартным ролям. Проверил, действительно так все работает, добавил пользователю роль Бухгалтер, создал свою роль и добавил этому пользователю еще и свою роль в которой больше прав, теперь все работает и ошибку не пишет: Недостаточно прав доступа. У текущего пользователя нет доступных ролей, для запуска информационной базы.

А вот если нужно пользователя Бухгалтер, ограничить в правах, то такой способ не подходит, по крайней мере у меня не получилось это сделать.

VasiliyV

  • Newbie
  • *
  • Сообщений: 2
    • Просмотр профиля
ИМХО ответ правильный но с точки срезния 1С некоректный.
Роль "Пользователь" является обязательной. Если конечно не используется роль "Полные права"
Тоесть решение простое, делаем нашу роль "Вася Пупкин" и добавляем пользователю Бухгалтер роли:
"Вася Пупкин" и "Пользователь"
так будет более правильно.

iPRG Team

  • Administrator
  • Full Member
  • *****
  • Сообщений: 188
    • Просмотр профиля
Да, в 1С 8.1 переделали механизм проверки новых ролей, в 8.1 теперь не нужно создавать перечисления. Я правда проверял на конфигурации Бухгалтерия предприятия 8.1, но думаю в УТ тоже самое.
После создания новой роли в конфигураторе, нужно еще исправить процедуру "ПроверитьВозможностьРаботыПользователя" в общем модуле "УправлениеПользователями":
В конфигураторе открываем "Общие модули" и там "УправлениеПользователями", ищем процедуру "ПроверитьВозможностьРаботыПользователя" и делаем в ней изменения:

Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт

Было так:
Если НЕ РольДоступна("ПолныеПрава") И НЕ РольДоступна("Бухгалтер") Тогда

Я добавил роль "Admin", исправляем так:
Если НЕ РольДоступна("ПолныеПрава") И НЕ РольДоступна("Бухгалтер")И НЕ РольДоступна("Admin") Тогда

Сохраняем конфигурацию и все работет.

VasiliyV

  • Newbie
  • *
  • Сообщений: 2
    • Просмотр профиля
Аналогичная проблема только 1С у меня 8.1
Добавил новую роль, и получил:Недостаточно прав доступа. У текущего пользователя нет доступных ролей, для запуска информационной базы.
Сразу скажу что замучался на форумах искать ответ.
в ПЕРЕЧИСЛЕНИЯХ, НЕТ "НАБОР ПРАВ ПОЛЬЗОВАТЕЛЕЙ".
там присутсвует только "УдалитьНаборПравПользователей" добавил в данное перечисление роль, не помогло.
далее стал искать, что именно выдает соообщение об ощибке нашел процедуру:
Общие модули>>Управление Пользователями

Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт
Если НЕ ПолныеПрава.ЕстьДоступныеПраваДляЗапускаКонфигурации() Тогда
Отказ = Истина;
#Если Клиент Тогда
Предупреждение("У текущего пользователя нет доступных ролей, для запуска информационной базы.", 10, "Недостаточно прав доступа";
#КонецЕсли
КонецЕсли;
КонецПроцедуры
Из процедуры видно, что если нет Полных прав начинается поиск в доступных правах. Собственно вопрос Где устанавливать эти самы права?
еще раз обращю внимание на платформу 8.1 ответ нужен именно для 8.1

iPRG Team

  • Administrator
  • Full Member
  • *****
  • Сообщений: 188
    • Просмотр профиля
В конфигураторе добавил новую роль (права доступа для пользователей).
Назначил эту новую роль пользователю и когда этот пользователь входит в программу 1С УТ, появляется ошибка и программа закрывается:
Недостаточно прав доступа. У текущего пользователя нет доступных ролей, для запуска информационной базы.

Такое не только в Управление торговлей, но и в конфигурации "Бухгалтерия предприятия 8"
Ты все правильно сделал, нужно еще добавить название твоей новой роли в:
Перечисления - НаборПравПользователей
и все заработает  ;)

int77

  • Newbie
  • *
  • Сообщений: 8
    • Просмотр профиля
В конфигураторе добавил новую роль (права доступа для пользователей).
Назначил эту новую роль пользователю и когда этот пользователь входит в программу 1С УТ, появляется ошибка и программа закрывается:
Недостаточно прав доступа. У текущего пользователя нет доступных ролей, для запуска информационной базы.

Пробовал создавать другие новые роли, интерфейс делать с таким же именем, но результат тот же.
Мне нужно всего лишь сделать доступ, чтобы пользователь все видел но не мог ничего редактировать, может есть какой нибудь другой способ это сделать?