Автор Тема: Отчет по нескольким документам  (Прочитано 7489 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Билл

  • Newbie
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Отчет по нескольким документам
« Ответ #3 : 11 Июнь 2009 Четверг 18:21:17 »
Большое спасибо! Всё получилось!

iPRG Team

  • Administrator
  • Full Member
  • *****
  • Сообщений: 188
    • Просмотр профиля
Re: Отчет по нескольким документам
« Ответ #2 : 11 Июнь 2009 Четверг 18:18:02 »
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Отчет");
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);

//Создаем документ Док1
Док=СоздатьОбъект("Документ.Док1");
//Создаем документ Док2
Док2=СоздатьОбъект("Документ.Док2");


//Делаем выборку по документу Док1 с НачДата по КонДата
Док.ВыбратьДокументы(НачДата,КонДата);
//В цикле перебираем все документы Док1 которые попали в выборку
Пока Док.ПолучитьДокумент()=1 Цикл
   Если ВыбКлиенты.Выбран()=1 Тогда
      //Если Условие не выполняется пропускаем документ
      Если ВыбКлиенты<>Док.Клиент Тогда
         Продолжить;
      КонецЕсли;
   КонецЕсли;
   //Это скорей всего сумма документа1 которая попадает в отчет в переменную тСумма
   тСумма=Док.Сумма;
   Таб.ВывестиСекцию("Строка_1");
КонецЦикла;

//*** Теперь перебираем второй документ ***
//Делаем выборку по документу Док2 с НачДата по КонДата
Док2.ВыбратьДокументы(НачДата,КонДата);
//В цикле перебираем все документы Док1 которые попали в выборку
Пока Док2.ПолучитьДокумент()=1 Цикл
   Если ВыбКлиенты.Выбран()=1 Тогда
      //Тут я исправил, в документе Док2 надо проверить, есть ли поле "Клиент" !!!
      //Если Условие не выполняется пропускаем документ
      Если ВыбКлиенты<>Док2.Клиент Тогда
         Продолжить;
      КонецЕсли;
   КонецЕсли;
   //Это скорей всего сумма документа2 которая попадает в отчет в переменную тСумма
   тСумма=Док.Сумма;
   Таб.ВывестиСекцию("Строка_1");
КонецЦикла;
« Последнее редактирование: 11 Июнь 2009 Четверг 18:20:13 от admin »

Билл

  • Newbie
  • *
  • Сообщений: 7
    • Просмотр профиля
Отчет по нескольким документам
« Ответ #1 : 11 Июнь 2009 Четверг 18:17:03 »
Доброго времени суток о великие профессионалы !!! Подскажите пожалуйста начинающему программисту!!!))) есть несколько документов и очень хочу сделать отчет где бы в одной таблице фигурировало несколько документов ниже привожу додуманный код одного документа
Процедура Сформировать()
Таб = СоздатьОбъект("Таблица" ) ;
Таб.ИсходнаяТаблица("Отчет" ) ;
Таб.ВывестиСекцию("Шапка" ) ;
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0 ) ;

//подкл док
Док=СоздатьОбъект("Документ.Док1" ) ;
Док2=СоздатьОбъект("Документ.Док2" ) ;
Док.ВыбратьДокументы(НачДата,КонДата) ;
Док2.ВыбратьДокументы(НачДата,КонДата) ;
//Док1
Пока Док.ПолучитьДокумент()=1 Цикл
Если ВыбКлиенты.Выбран()=1 Тогда
Если ВыбКлиенты<>Док.Клиент Тогда
Продолжить ;
КонецЕсли;
КонецЕсли;
тСумма=Док.Сумма;

Таб.ВывестиСекцию("Строка_1" ) ;

КонецЦикла;
Как сюда воткнуть док2???
В заранее спасибо!!!!